Command ‘mlflow’ not found - After doing `pip install mlflow`

I have already installed anaconda navigator (root).

mlflow ui command does not open up the GUI and leads to the following message.

Command ‘mlflow’ not found, did you mean:
command ‘mflow’ from deb mblaze
Try: sudo apt install

pip3 install mlflow command was used and to verify whether the mlflow was installed I ran the command again (see the below picture)

Typically it should inform that Requirement already satisfied, but what I see is that it is just installing (I don’t know whether mlflow is getting installed as whenever the command is run it is not showing as mlflow is already installed). That means it is not getting installed or is there anything wrong I am doing here?.

Then I tried invoking the mlflow gui by using mlflow ui and what it shows is the following information (see the below picture)

I tried reading these links https://github.com/mlflow/mlflow/issues/599 , https://github.com/mlflow/mlflow/issues/1116 but I am not getting the problem fixed.

I do not know whether there is issue in environment or something else (pip3 or conda). Kindly, help me with this regard.

Try out some solutions from here and see if that helps:

1 Like