Integrating Google Colab with Jupiter Notebook

Hello everyone, I am unable to integrate google colab with Jupyter Notebook… Every time I tried the same error message appears saying “Unable to connect local runtime”…

Same issue with me as well.

Hope the community and @admins will help me out.I am stuck here for almost 24 Hrs, I am running out of time since my project is yet to be completed and the deadline is 31st July. I am a Feb-19 DL course student and already very late. Being a Non-CS background student, it’s very difficult to get over these technicalities, Don’t know I will be able to complete it or not…

I would suggest you to start with next chapters and understand the concept of this chapter without actually implementing it yourself until someone helps regarding this. Later chapters doesn’t trouble with this issue.

1 Like

Hi @Shashi_Singh,
Have you tried opening these URLs directly into your browser, rather than opening it as a colab link?

I tried connecting to local runtime option first time today, using the instructions at the link below. It worked for me.

Can you make sure you have followed all steps, Step No: 3 in particular?

https://research.google.com/colaboratory/local-runtimes.html

No,the URL http://localhost:8888/tree opened when I ran Jupyter notebook as suggested by Pratysh sir, and copied the URL and token from Jupyter notebook and pasted into Google Colab to connect with local runtime, but failed…

For a simple case, can you try to directly open thi URL in your web browser, or please note the point made by @sanjayk.

I have noted and tried these steps multiple times as suggested by google colab instructions @sanjayk . I am working through anaconda navigation, is this the problem?

But what I observed is

 --NotebookApp.allow_origin='https://colab.research.google.com' \
  --port=8888 \
  --NotebookApp.port_retries=0```

This command doesn't operate in entirety and only 1st line of command directs to the URL  http://localhost:8888/tree

I think, You are working on Python 3.7 installed on your MacBook . I am accessing Jupiter Notebook through Anaconda navigation, Does this make any difference ?

Python 3.7 (and Jupyter) on my machine are installed as part of anaconda installation only. (default python version on mac is still 2.7, surprised?)

Anyways, in the screenshot above, I just wanted to highlight that I had executed all of the multi-line command and not just the first line.

Please Look into this, and help out of this please…

doesn’t allow access.

Tell me how can I share with you? I shared with you the Google-drives shareable link, don’t know how it became restricted…

What are you trying to share? This issue is on your local system? Right?

  • If you want somebody to look at your local system, you can use this:
    https://remotedesktop.google.com/support/
    Here you choose get support, and generate a code, share the code with the person (at remote) to let them access your local system.

  • if its something on the drive, you can enable access to all (instead of restricted)
    Screenshot 2020-07-26 at 9.38.19 PM

  • and, same as google drive for notebooks on google colab.

Atleast the command seems to be running fine. Can you copy paste the url and trying connecting to local host one more time? (I’m not able to copy from your terminal through this session)
Screenshot 2020-07-26 at 9.59.03 PM

Finally, Issue has been resolved. Thank You for your kind help @sanjayk it was so great on your part to go out of the way for my help.

Great, I will mark previous post (containing Step 3 execution carefully) as solution.

1 Like

Yes, However one need to carefully check before executing the command and pasting the token that no space left in-between.